jQuery AJAX跨域在IE9及以下版本中失效问题

        使用jQuery AJAX在IE9及以下版本浏览器中提交HTTP跨域请求时,浏览器会报错且并不执行该操作,是因为IE9及以下版本默认不支持跨域请求。主要有以下几个办法解决:(1)修改IE设置:工具->Internet选项->安全->Internet->自定义级别->通过域访问数据源->启用,但此设置对于用户自行操作不现实;(2)将请求页面与被请求页面转换为同域,例如使用自行实现的代理;(3)调用AJAX前,设置$.support.cors = true,另外被请求页面需输出跨域Header设置。

        

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://www.9icode.com/index.php/post/17.html

我要评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。